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SSMUG NEWSLETTER
August 2014

Meetings
Second Tuesday of the month
Flossmoor Station meeting room
(reservation under “Todd Smith”)
confirm: tsmith@mac.com
The format is different this moth because I am passing along some of Apple’s keyboard shortcut command charts.
Apple has not been announcing much since WWDC in May. Speculation and leaks about the iPhone 6 and the “iWatch”
are rife. The quotes are around “iWatch” because someone else has registered the term as a trademark.
It is clear that the iPhone 6 will come in two sizes, ‘Large’ in September (Apple has “blacked out” vacations in
September for Apple Store employees. However, this is customary. This points to new product introduction, but nothing
out of the ordinary (for Apple) because they are not hiring more people for the stores.) and “Extra Large” shortly
thereafter. Neither will be as large as Samsung’s “Phablets”, however. I am not publishing the leaks because the only
thing they show that is new, except for size, is that there is a recess on the inside of the case where the Apple is located,
leading to speculation that it will be lit as with MacBooks.
Engineers are still being hired to work on Apple’s smart watch. While I am aware that product development does not
stop once a product goes to market, it does give a certain sense of foreboding that things are not going as well as might be
expected. As well as we hope, that is.
Apple’s sales are holding up and Samsung’s dropped last quarter. Since Apple introduced the iPhone in China sales have
been good. Good enough the Chinese government has been attacking the iPhone as foreign.

From the iOS 8 Beta:
http://support.apple.com/kb/ht1533
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This shows what Healthbook will monitor. There has to be some kind of input device and I think it is clear that the device
they are planning on is the “iWatch”. Having been an assistant caregiver to two elderly person for the past four years, I
can say that there are many items on the list that it would be useful to track on a continuing basis. Doctor visits only
check these thoings when the Doctor or drugstore is visited these would be ongoing measurements. When push comes to
shove, you question what normal is and what is going on between measurements. This way you can see what happened
and when it started. This can give information about possible causes. This will reduce the guesswork and provide
monitoring previously only available in hospitals or research labs.
I am puzzled as to what the term “Bloodwork” refers to because many of the items included in that term are broken out. I
am 66 years old, so I take a strong interest in this kind of thing.

Mobile Devices and Twitter Use

http://support.apple.com/kb/ht1533
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Wireless charging:
(from The Verge)
Two alliances team up to win the wireless charging war

Why can't you just place your phone on a table and have it wirelessly charge? Until today, there were three competing
standards that couldn't agree on how the proven technology should work. The Wireless Power Consortium (WPC), the
Power Matters Alliance (PMA), and the Alliance for Wireless Power (A4WP) each attracted a number of powerful
companies, but their chargers didn't play nice with one another. With too many "standards" on the table, consumers and
businesses have understandably been hesistant to adopt any of them.
That may be about to change. Today, the A4WP and PMA have signed a preliminary agreement to each adopt the other's
technologies, effectively merging into a single standard. That leaves Qi as the only other competitor.
“"We saw an opportunity to remove the barrier to adoption."
Technically, it's a little bit more complex than that. According to the presidents of both alliances, the PMA and A4WP
aren't completely merging their organizations, and they also won't necessarily be combining their two different charging
methods into a single brand like Rezence quite yet. They've simply come to the conclusion that each group had a piece of
the puzzle that the other needed. The PMA gets the A4WP's so-called resonant wireless charging spec, which can
wirelessly charge several gadgets at once, and without requiring them to be oriented in any particular direction on a
charging pad. The A4WP gets the PMA's legacy inductive charging tech, plus cloud-based software infrastructure for
managing and monetizing charging points, which could direct smartphone users to the nearest charging hotspot when
they're low on juice, and allow Starbucks to let its customers top off those devices with the purchase of a latte.
What both parties get, though, is a leg up on Qi. Originally, the Wireless Power Consortium's Qi standard was the fronthttp://support.apple.com/kb/ht1533
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runner in wireless charging — attracting device manufacturers like HTC, LG, and Samsung to build phones and tablets
with the tech — but over the past couple years the PMA and A4WP have attracted a host of supporters, including Intel,
AT&T, Starbucks, McDonalds (via PowerKiss), and The Coffee Bean and Tea Leaf. Qualcomm and Samsung have been
playing the field, presumably hedging their bets, but both are founding members of the A4WP. WiTricity, the MIT
spinoff that invented resonant wireless charging, is now an A4WP member as well.
“The stars are beginning to align for wireless charging tech”
The competing Wireless Power Consortium hasn't been sitting idly, mind you, inking deals with PowerbyProxi and Texas
Instruments to build its own resonant charging solution, and attracting Verizon Wireless and Qualcomm with seats on the
WPC board. But even if we're left with two competing standards bodies, the idea has the potential to snowball now that
so many companies are aligned. With upcoming dual-mode devices that support both PMA inductive and A4WP resonant
wireless charging, the two cooperating alliances believe the wireless charging market can open up. "Because of the
collaboration, you've future-proofed yourself going forward," says A4WP president Kamil Grajski. "There's no reason for
anyone to hesitate any longer."
I am not a fan of wireless charging if it means that I have to plug in a charging pad and place my device on it. Nor am I a
fan of loading the air with electrical waves that interfere with Bluetooh, WiFi or telephone signals. Is there a third way?

Following are some document from Apple’s website. PLEASE do not ask why I developed an interest in this kind of thing. You do not want to
know.

Startup key combinations for Intel-based Macs

Languages

English

Learn about the startup key combinations you can use with Intel-based Macs.

You can use the following startup key combinations with Intel-based Macs.
Keystroke
Press C during startup
Press D during startup
Press Option-Command-P-R until you hear
startup sound a second time.
Press Option during startup
Press Eject, F12, or hold the mouse or
trackpad button

Description
Start up from a bootable CD, DVD, or USB thumb drive (such as
OS X install media).
Start up in Apple Hardware Test (AHT).
Reset NVRAM
Start up in Startup Manager, where you can select an OS X
volume or network volume to start from.
Ejects any removable media, such as an optical disc.

Press N during startup

Attempt to start up from a compatible network server (NetBoot).

Press T during startup

Start up in Target Disk Mode.

Press Shift during startup

Start up in Safe Boot mode and temporarily disable login items.

Press Command-V during startup

Start up in Verbose mode.

Press Command-S during startup

Start up in Single-User mode.

Press Option-N during startup

Start from a NetBoot server using the default boot image.

Press Command-R during startup

Start from the OS X Recovery System 1

1 Available on Macs that ship with OS X Lion. Some CPUs require an EFI BootROM update to support this feature.
http://support.apple.com/kb/ht1533
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OS X keyboard shortcuts

Languages

English

A keyboard shortcut is a way to invoke a function in OS X by pressing a combination of keys on your
keyboard. Learn about common OS X keyboard shortcuts.

To use a keyboard shortcut you press a modifier key with a character key. For example, pressing the Command key
(it has a

symbol) and then the "c" key copies whatever is currently selected (text, graphics, and so forth) into the

Clipboard. This is also known as the Command-C keyboard shortcut.
A modifier key is a part of many keyboard shortcuts. A modifier key alters the way other keystrokes or
mouse/trackpad clicks are interpreted by OS X. Modifier keys include: Command, Shift, Option, Control, Caps Lock,
and the Fn key. You may need to use the Fn key in some of the key combinations listed below. For example, if the
keyboard shortcut is Control-F2, press Fn-Control-F2.
Here are the modifier key symbols you may see in OS X menus:
⌘

Command key

⌃

Control key

⌥

Option key

⇧

Shift Key

⇪

Caps Lock

Fn

Function Key

Startup shortcuts
Press the key or key combination until the expected function occurs/appears (for example, hold Option during
startup until Startup Manager appears). Note: If a startup function doesn't work and you use a third-party
keyboard, try again with an Apple keyboard.
Key or key combination

What it does

Option

Display all bootable volumes (Startup Manager)

Shift

Start up in Safe Mode

Left Shift

Prevent automatic login
Start from bootable media (DVD, CD, USB thumb

C

drive, and so forth)

T

Start up in Target disk mode

N

Start from a NetBoot server

X

Force Mac OS X startup (if non-Mac OS X startup
volumes are present)

D

Use Apple Hardware Test

Command-R

Use OS X Recovery (OS X Lion or later)

Command-V

Start up in Verbose Mode

Command-S

Start up in Single User Mode

Command-Option-P-R

Reset NVRAM / parameter RAM

Hold down the Media Eject (⏏) key or F12 key, or mouse
or trackpad button

Eject removable discs

Sleep and shut down shortcuts

http://support.apple.com/kb/ht1343
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Key or key combination

What it does

Power button – OS X Mavericks

Tap to power on. Once powered on, tap to wake or sleep.

Hold down the power button for 1.5
seconds – OS X Mavericks
Hold down the power button for 5
seconds

Show restart / sleep / shutdown dialog

Force the Mac to power off

Command-Control-power button

Force the Mac to restart

Control-Media Eject (⏏)

Show restart / sleep / shutdown dialog

Command-Option-Media Eject (⏏)

Put the computer to sleep

Command-Control-Media Eject (⏏)

Quit all applications (after giving you a chance to save changes to open
documents), then restart the computer

Command-Option-Control-Media

Quit all applications (after giving you a chance to save changes to open

Eject (⏏)

documents), then shut down the computer

Shift-Control-Media Eject (⏏)

Put all displays to sleep

Finder keyboard shortcuts
Key combination
Command-A

What it does
Select all items in the front Finder window (or desktop if no
window is open)

Command-Option-A

Deselect all items

Command-Shift-A

Open the Applications folder

Command-C

Copy selected item/text to the Clipboard

Command-Shift-C

Open the Computer window

Command-D

Duplicate selected item

Command-Shift-D

Open desktop folder

Command-E

Eject

Command-F

Find any matching Spotlight attribute

Command-Shift-F

Find Spotlight file name matches

Command-Option-F
Command-Shift-G
Command-Shift-H

Navigate to the search field in an already-open Spotlight
window
Go to Folder
Open the Home folder of the currently logged-in user
account

Command-Shift-Control-T

Add to Dock

Command-I

Get Info

Command-Option-I

Show Inspector

Command-Control-I

Get Summary Info

Command-Shift-I

Open iDisk

Command-J

Show View Options

Command-K

Connect to Server

Command-Shift-K

Open Network window

Command-L

Make alias of the selected item

Command-M

Minimize window

http://support.apple.com/kb/ht1343
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Command-Option-M

Minimize all windows

Command-N

New Finder window

Command-Shift-N

New folder

Command-Option-N

New Smart Folder

Command-O

Open selected item

Command-Shift-Q

Log Out

Command-Shift-Option-Q

Log Out immediately

Command-R

Show original (of alias)

Command-T

Add to Sidebar

Command-Shift-T

Add to Favorites

Command-Option-T

Hide Toolbar / Show Toolbar in Finder windows

Command-Shift-U

Open Utilities folder

Command-V

Paste Command-

W

Close window

Command-Option-W

Close all windows

Command-X

Cut

Command-Option-Y

Slideshow (Mac OS X v10.5 or later)

Command-Z

Undo / Redo

Command-1

View as Icon

Command-2

View as List

Command-3

View as Columns

Command-4

View as Cover Flow (Mac OS X v10.5 or later)

Command-Comma (,)

Open Finder preferences

Command-Accent (`) (the Accent key above Tab
key on a US English keyboard layout)

Cycle through open Finder windows

Command-Shift-Question Mark (?)

Open Mac Help

Command-Left Bracket ([)

Go to the previous folder

Command-Right Bracket (])

Go to the next folder

Command-Up Arrow

Open the folder that contains the current folder

Command-Control-Up Arrow

Open the folder that contains the current folder in a new
window

Command-Down Arrow

Open highlighted item

Command-Shift-Up Arrow

Make the desktop active

Right Arrow (in List view)

Open the selected folder

Left Arrow (in List view)

Close the selected folder

Option-click the disclosure triangle (in List view)

Open all folders within the selected folder

Option–double-click

Open a folder in a separate window, closing the current
window

Command–double-click

Open a folder in a separate window

Command-click the window title

See the folders that contain the current window

Command-Tab

Switch application–cycle forward

Command-Shift-Tab

Switch application–cycle backward

Command-Delete

Move to Trash

http://support.apple.com/kb/ht1343
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Command-Shift-Delete

Empty Trash

Command-Shift-Option-Delete

Empty Trash without confirmation dialog

Space bar (or Command-Y)

Quick Look (Mac OS X v10.5 or later)
Move dragged item to other volume/location (pointer icon

Command key while dragging

changes while key is held--see this article)
Copy dragged item (pointer icon changes while key is held-

Option key while dragging

-see this article)

Command-Option key combination while dragging

Make alias of dragged item (pointer icon changes while key
is held--see this article)

Application and other OS X shortcuts
Note: Some applications may not support all of the following application key combinations.
Key combination
Command-Space bar

What it does
Show or hide the Spotlight search field (if multiple languages are installed, may
rotate through enabled script systems)

Control-A

Move to beginning of line/paragraph

Control-B

Move one character backward

Control-D

Delete the character in front of the cursor

Control-E

Move to end of line/paragraph

Control-F

Move one character forward

Control-H

Delete the character behind the cursor

Control-K

Delete from the character in front of the cursor to the end of the line/paragraph

Control-L

Center the cursor/selection in the visible area

Control-N

Move down one line

Control-O

Insert a new line after the cursor

Control-P

Move up one line

Control-T

Transpose the character behind the cursor and the character in front of the cursor

Control-V

Move down one page

Option-Delete

Delete the word that is left of the cursor, as well as any spaces or punctuation
after the word

Command-Option-Space

Show the Spotlight search results window (if multiple languages are installed, may

bar

rotate through keyboard layouts and input methods within a script)

Command-Tab

Move forward to the next most recently used application in a list of open
applications

Command-Shift-Tab

Move backward through a list of open applications (sorted by recent use)

Shift-Tab

Navigate through controls in a reverse direction

Control-Tab

Move focus to the next grouping of controls in a dialog or the next table (when
Tab moves to the next cell)

Shift-Control-Tab

Move focus to the previous grouping of controls

Command-esc

Open Front Row (if installed)

Option-Media Eject (⏏)

Eject from secondary optical media drive (if one is installed)

Fn-Delete

Forward Delete (on a portable Mac's built-in keyboard)

Command-F1

Toggles "Mirror Displays" for multi-monitor configurations

Command-F2

Toggle Target Display Mode

http://support.apple.com/kb/ht1343

Page 5 of 10

OS X keyboard shortcuts

6/1/14, 7:40 AM

Command-F3

Show Desktop

Command-F5

Toggle VoiceOver On / Off

Option-F1 or F2

Opens "Displays" System Preference

Option-F3 or F4

Opens "Mission Control" System Preference

Option-F10 or F11 or F12

Opens "Sound" System Preference

Control-F3

App Exposé

Shift-Control-F6

Move focus to the previous panel

Control-F7

Temporarily override the current keyboard access mode in windows and dialogs

Control-F8

Move to the status menus in the menu bar

F9

Tile or untile all open windows

F10

Tile or untile all open windows in the currently active application

F11

Hide or show all open windows

F12

Hide or display Dashboard

Command-Accent (`)

Activate the next open window in the frontmost application

Command-Shift-Accent (`)

Activate the previous open window in the frontmost application

Command-Option-Accent
(`)

Move focus to the window drawer

Command-Minus (–)

Decrease the size of the selected item

Command-{

Left-align a selection

Command-}

Right-align a selection

Command-|

Center-align a selection

Command-Colon (:)

Display the Spelling window

Command-Semicolon (;)

Find misspelled words in the document

Command-Comma (,)
Command-Option-ControlComma (,)
Command-Option-ControlPeriod (.)
Command-Question Mark
(?)

Open the front application's preferences window (if it supports this keyboard
shortcut)
Decrease screen contrast

Increase screen contrast

Open the application's help in Help Viewer

Command-Option-/

Turn font smoothing on or off

Command-Shift-=

Increase the size of the selected item

Command-Shift-3

Capture the screen to a file

Command-Shift-Control-3

Capture the screen to the Clipboard

Command-Shift-4

Capture a selection to a file

Command-Shift-Control-4

Capture a selection to the Clipboard

Command-A

Highlight every item in a document or window, or all characters in a text field

Command-B

Boldface the selected text or toggle boldfaced text on and off

Command-C

Copy the selected data to the Clipboard

Command-Shift-C

Display the Colors window

Command-Option-C

Copy the style of the selected text

Command-Control-C

Copy the formatting settings of the selected item and store on the Clipboard

Command-Option-D

Show or hide the Dock

http://support.apple.com/kb/ht1343
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Command-Control-D

Display the definition of the selected word in the Dictionary application
Selects the Desktop folder in Open and Save dialogs

Command-D

or
Selects "Don't Save" in dialogs that contain a Don't Save button, in Mac OS X
v10.6.8 and earlier

Command-Delete

Selects "Don't Save" in dialogs that contain a Don't Save button, in OS X Lion and
Mountain Lion

Command-E

Use the selection for a find

Command-F

Open a Find window

Command-Option-F

Move to the search field control Command-G
Find the next occurrence of the selection

Command-Shift-G

Find the previous occurrence of the selection

Command-H

Hide the windows of the currently running application

Command-Option-H

Hide the windows of all other running applications

Command-I

Italicize the selected text or toggle italic text on or off

Command-Option-I

Display an inspector window

Command-J

Scroll to a selection

Command-M

Minimize the active window to the Dock

Command-Option-M

Minimize all windows of the active application to the Dock

Command-N

Create a new document in the frontmost application

Command-O

Display a dialog for choosing a document to open in the frontmost application

Command-P

Display the Print dialog

Command-Shift-P

Display a dialog for specifying printing parameters (Page Setup)

Command-Q

Quit the frontmost application

Command-S

Save the active document

Command-Shift-S

Display the Save As dialog

Command-T

Display the Fonts window

Command-Option-T

Show or hide a toolbar

Command-U

Underline the selected text or turn underlining on or off

Command-V

Paste the Clipboard contents at the insertion point

Command-Option-V

Apply the style of one object to the selected object (Paste Style)

Command-Shift-Option-V

Apply the style of the surrounding text to the inserted object (Paste and Match
Style)

Command-Control-V

Apply formatting settings to the selected object (Paste Ruler Command)

Command-W

Close the frontmost window

Command-Shift-W

Close a file and its associated windows

Command-Option-W

Close all windows in the application without quitting it

Command-X

Remove the selection and store in the Clipboard

Command-Z

Undo previous command (some applications allow for multiple Undos)

Command-Shift-Z

Redo previous command (some applications allow for multiple Redos)

Control-Right Arrow

Move focus to another value or cell within a view, such as a table

Control-Left Arrow

Move focus to another value or cell within a view, such as a table

Control-Down Arrow

Move focus to another value or cell within a view, such as a table

Control-Up Arrow

Move focus to another value or cell within a view, such as a table

http://support.apple.com/kb/ht1343
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Command-Right Arrow

Move the text insertion point to the end of the current line

Command-Left Arrow

Move the text insertion point to the beginning of the current line

Command-Down Arrow

Move the text insertion point to the end of the document

Command-Up Arrow

Move the text insertion point to the beginning of the document

Option-Right Arrow

Move the text insertion point to the end of the next word

Option-Left Arrow

Move the text insertion point to the beginning of the previous word

Command-Shift-Right
Arrow

Select text between the insertion point and the end of the current line (*)

Command-Shift-Left Arrow

Select text between the insertion point and the beginning of the current line (*)

Shift-Right Arrow

Extend text selection one character to the right (*)

Shift-Left Arrow

Extend text selection one character to the left (*)

Command-Shift-Up Arrow

Select text between the insertion point and the beginning of the document (*)

Command-Shift-Down
Arrow
Shift-Up Arrow

Select text between the insertion point and the end of the document (*)
Extend text selection to the line above, to the nearest character boundary at the
same horizontal location (*)
Extend text selection to the line below, to the nearest character boundary at the

Shift-Down Arrow

Shift-Option-Right Arrow

Shift-Option-Left Arrow

Shift-Option-Down Arrow

Shift-Option-Up Arrow

same horizontal location (*)

Extend text selection to the end of the current word, then to the end of the
following word if pressed again (*)
Extend text selection to the beginning of the current word, then to the beginning
of the following word if pressed again (*)
Extend text selection to the end of the current paragraph, then to the end of the
following paragraph if pressed again (*)
Extend text selection to the beginning of the current paragraph, then to the
beginning of the following paragraph if pressed again (*)

Control-Space bar

Toggle between the current and previous input sources

Option-Control-Space bar

Toggle through all enabled input sources

Command-Option-esc

Force Quit

Command-Shift-Option-Esc
(hold for three seconds)

Force Quit the front-most application (Mac OS X v10.5 or later)

Command-Left Bracket ([)

Previous browser webpage

Command-Right Bracket (])

Next browser webpage

*Note: If no text is selected, the extension begins at the insertion point. If text is selected by dragging, then the
extension begins at the selection boundary. Reversing the direction of the selection deselects the appropriate
unit.

Universal Access - VoiceOver keyboard commands
For information about VoiceOver key combination differences in Mac OS X v10.6, see this article.
Key combination

What it does

Command-F5 or Fn-Command-F5

Turn VoiceOver on or off

Option-Control-F8 or Fn-Option-Control-F8

Open VoiceOver Utility (if VoiceOver is on)

Option-Control-F7 or Fn-Option-Control-F7

Display VoiceOver menu (if VoiceOver is on)

Option-Control-Semicolon (;)

Enable/disable VoiceOver Control Option-lock

http://support.apple.com/kb/ht1343
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Command-Option-8

Turn Zoom on or off

Command-Option-Plus (+)

Zoom In

Command-Option-Minus (–)

Zoom Out

Command-Option-Control-8

Invert/revert the screen colors (OS X Lion or earlier)

Command-Option-Control-Comma (,)

Reduce contrast (OS X Lion or earlier)

Command-Option-Control-Period (.)

Increase contrast (OS X Lion or earlier)

Note: You may need to enable "Use all F1, F2, etc. keys as standard keys" in Keyboard preferences for the
VoiceOver menu and utility to work.

Full keyboard access
Full keyboard access lets you use your keyboard to navigate and interact with items on the screen. Use these
shortcuts to select and adjust controls such as text fields and sliders.
Key combination

What it does

Tab

Move to the next control

Shift-Tab

Move to the previous control

Control-Tab

Move to the next control when a text field is selected
Move to the adjacent item in a list, tab group, or menu

or
Arrow keys

Move sliders and adjusters (vertical up and down arrows used to increase and decrease
values)

Control-Arrow
keys

Move to a control adjacent to the text field

Space bar

Select the highlighted menu item

Return or Enter

Click the default button or perform the default action
Click the Cancel button

Esc

or
Close a menu without choosing an item

You can navigate the menus in the menu bar without using a mouse or trackpad. To put the focus in the menu
bar, press Control-F2 (Fn-Control-F2 on portable keyboards). Then use the key combinations listed below.
Key combination

What it does

Left Arrow and Right Arrow

Move from menu to menu

Return

Open a selected menu

Up Arrow and Down Arrow

Move to menu items in the selected menu

Type the menu item’s name

Jump to a menu item in the selected menu

Return

Select a menu item

Universal Access - Mouse Keys
When Mouse Keys is turned on in Universal Access preferences, you can use the keyboard or numeric keypad keys
to move the mouse pointer. If your computer doesn't have a numeric keypad, use the Fn (function) key.
Key combination

What it does

8

Move Up

2

Move Down

http://support.apple.com/kb/ht1343
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4

Move Left

6

Move Right

1

Move Diagonally Bottom Left

3

Move Diagonally Bottom Right

7

Move Diagonally Top Left

9

Move Diagonally Top Right

5

Press Mouse Button

0

Hold Mouse Button

. (Period on number pad)

Release Hold Mouse Button

See also: Shortcuts for Mouse Keys.

Additional Information
Advanced: This article refers to the default modifier key assignments. Modifier key assignments can be changed
in the Keyboard preferences pane of System Preferences. For example, you can change the Command key to act
as an Option key, and vice-versa. You can also restore default modifier key settings.
See also:
Creating keyboard shortcuts for applications
If a keyboard shortcut doesn’t work
Startup Manager: How to select a startup volume
Resolving VoiceOver key command conflicts
Additional features of the Dock
How to Add a Spoken Command for Keyboard Shortcut

Last Modified: Jan 13, 2014

Helpful?

Yes

No

Related
OS X Mavericks: If you can’t use
some keyboard shortcuts

OS X Mountain Lion: If you can’t use
some keyboard shortcuts

Final Cut Pro X: View keyboard
shortcuts in the Command Editor

Some full keyboard access shortcuts
may be unavailable in some apps. Make
sure you’re using the latest OS X
version of the app.

Some full keyboard access shortcuts
may be unavailable in some apps. Make
sure you’re using the latest OS X
version of the app.

The Command Editor provides a set of
keyboard shortcuts for Final Cut Pro in
English, Japanese, French, and German.
The language that is shown is
determined by your computer’s

Are there keyboard shortcuts for
navigating a page in Safari?

Trying to learn keyboard shortcuts,
can't find the ⌃ on the keyboard

Move Mac OS X menu bar for the
active application into its window?

The top ones take you right to the top
or bottom of the window, the lower
ones ditto (or sideways) one line at a
time. Mac OS X keyboard shortcuts :
and more useful information on

For a more complete list of Keyboard
symbols, please see: macOSXhints For
more on keyboard shortcuts that you
can use, see: Mac OS X keyboard
shortcuts Ivan

Please don't suggest that I learn
keyboard shortcuts . There are lots of
menu commands that don't have
shortcut equivalents.

http://support.apple.com/kb/ht1343
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Keyboard Shortcuts
Keyboard shortcuts can provide an easy way for sophisticated users to perform actions, but
they’re not required. If you can’t find a unique and easy-to-use keyboard shortcut for a
command, don’t use one at all; keep in mind that users may have difficulty pressing multiple
modifier keys anyway.
Important: Always respect the system-reserved keyboard shortcuts in your app so that
users aren’t confused when the shortcuts they know work differently in your app.

Creating New Keyboard Shortcuts
Avoid creating a shortcut by adding a modifier key to an existing shortcut, unless the
shortcuts are related. For example, don’t use Shift-Command-Z as a keyboard shortcut for a
command that is unrelated to Undo. Using Shift-Command-Z for Redo is appropriate, but
using it for something like Calculate or Check Mail is confusing.
As much as possible, use the Command key as the main modifier key in a keyboard
shortcut. For example, Command-P uses Command to modify the P key. For a command that
complements another more common command, you can add Shift to the shortcut. For
example, the shortcut for the complementary Page Setup command adds Shift to the shortcut
for Print to give Shift-Command-P. Table A-1 gives additional examples of this technique.

Table A-1 Examples of keyboard shortcuts that use Shift to complement other commands
Complementary
command
shortcut

Complementary command

Complemented
command
shortcut

Shift-Command-A

Deselect All

Command-A
(Select All)

Shift-Command-G

Find Previous

Command-G (Find
Again)

Shift-Command-P

Page Setup

Command-P
(Print)

Shift-Command-S

Save As

https://developer.apple.com/library/mac/documentation/userexperience/conceptual/applehiguidelines/KeyboardShortcuts/KeyboardShortcuts.html
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(Save)
Shift-Command-V

Paste as (Paste as Quotation, for example)

Command-V
(Paste)

Shift-Command-Z

Redo (when Undo and Redo are separate
commands rather than toggled using
Command-Z)

Command-Z
(Undo)

Note: Other languages may require modifier keys to generate certain characters. For
example, on a French keyboard, Option-5 generates the “{“ character. It’s usually safe to
use the Command key as a modifier, but avoid using Command and an additional modifier
key with characters not available on all keyboards. If you must use a modifier key in
addition to the Command key, try to use it only with the alphabetic characters (a through z).

Use the Option key sparingly. If there’s a third, less common command that’s related to a
pair of commands that use Command and Shift-Command, you can use Option-Command for
the third command’s keyboard equivalent. Use combinations like these very rarely. You can
also use Option for a keyboard shortcut that’s a convenience or power-user feature. For
example, the Finder uses Option-Command-W for Close All Windows and Option-CommandM for Minimize All Windows.
As much as possible, avoid using the Control key. Because the Control key is already used
by some of the universal access features—as well as in Cocoa text fields where Emacs-style
key bindings are often used—it should be used as a modifier key only when necessary.
List multiple modifier keys in the correct order. If you use more than one modifier key in a
shortcut, always list them in this order: Control, Option, Shift, Command.
Identify a key with two characters by the lower character, unless Shift is part of the
shortcut. For example, the keyboard shortcut for Hide Status Bar is Command-Slash (that is,
Command-/). If the Shift key is part of the keyboard shortcut, identify the key by the upper of
the two characters. For example, the keyboard shortcut for Help is Shift-Command-Question
Mark, not Shift-Command-Slash.

Keyboard Shortcuts Quick Reference
Table A-2 lists the system-reserved and commonly used keyboard shortcuts mentioned in the
rest of this document.
As you implement keyboard shortcuts in your app, use this table to find:
Key sequences that are reserved by OS X.

https://developer.apple.com/library/mac/documentation/userexperience/conceptual/applehiguidelines/KeyboardShortcuts/KeyboardShortcuts.html
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Users rely on these shortcuts to perform the specified actions no matter which app is
currently running (these include shortcuts reserved for accessibility purposes). Don’t
override these shortcuts.
Key sequences that are recommended for common app tasks.
Users expect these shortcuts to mean the same thing from app to app. Provide these
shortcuts if your app performs the associated tasks.
If your app doesn’t perform the task associated with a recommended shortcut, think very
carefully before you consider overriding it. Remember that although reassigning an unused
shortcut might make sense in your app, your users are likely to know and expect the
original, established meaning.
If a keyboard sequence isn’t listed in Table A-2 you can use it for a frequently used command
in your app, if a shortcut is appropriate. Be aware, however, that Apple may reserve other
keyboard shortcuts in the future.
Note: With the exception of the system-reserved function keys F9, F10, F11, and F12, Table
A-2 lists only combinations of two or more keys.

Table A-2 groups together the primary key that is modified and variations of key sequences
based on the primary key. In the interests of space, the table uses the following symbols to
represent the modifier keys (these are the same symbols that menus display):
(Control)
(Option)
(Shift)
(Command)
Some shortcuts in Table A-2 are accompanied by an
icon. This means that you should not
override the shortcut because OS X uses it in some way.
A shortcut in Table A-2 that isn’t accompanied by an
perform the associated task.

icon is recommended for apps that

Table A-2 Keyboard shortcuts
Primary
key

Space bar

Key
sequence

Space

Space

Associated action
Show or hide the Spotlight search field (when multiple
languages are installed, may rotate through enabled script
systems).

Apple reserved.

https://developer.apple.com/library/mac/documentation/userexperience/conceptual/applehiguidelines/KeyboardShortcuts/KeyboardShortcuts.html
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Show the Spotlight search results window (when multiple
languages are installed, may rotate through keyboard
layouts and input methods within a script).
Show the Special Characters window.

Tab

Navigate through controls in a reverse direction.

Tab

Move forward to the next most recently used app in a list of
open apps.

Tab

Tab

Tab

Move backward through a list of open apps (sorted by
recent use).
Move focus to the next grouping of controls in a dialog or
the next table (when Tab moves to the next cell). See
Accessibility Overview for OS X.
Move focus to the previous grouping of controls. See
Accessibility Overview for OS X.

Esc

Esc

Open the Force Quit dialog.

Eject

Eject

Quit all apps (after giving the user a chance to save changes
to open documents) and restart the computer.

Eject

Quit all apps (after giving the user a chance to save changes
to open documents) and shut the computer down.

F1

F1

Toggle full keyboard access on or off. See Accessibility
Overview for OS X.

F2

F2

Move focus to the menu bar. See Accessibility Overview for
OS X.

F3

F3

Move focus to the Dock. See Accessibility Overview for OS X.

F4

F4

Move focus to the active (or next) window. See Accessibility
Overview for OS X.

F4

F5

F5

Move focus to the previously active window. See
Accessibility Overview for OS X.
Move focus to the toolbar. See Accessibility Overview for OS
X.
Turn VoiceOver on or off. See Accessibility Overview for OS

https://developer.apple.com/library/mac/documentation/userexperience/conceptual/applehiguidelines/KeyboardShortcuts/KeyboardShortcuts.html
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F6

F5

X.

F6

Move focus to the first (or next) panel. See Accessibility
Overview for OS X.

F6

F7
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F7

Move focus to the previous panel. See Accessibility Overview
for OS X.
Temporarily override the current keyboard access mode in
windows and dialogs. See Accessibility Overview for OS X.

F8

Apple reserved.

F9

Apple reserved.

F10

Apple reserved.

F11

Show desktop.

F12

Hide or display Dashboard.

`(grave
accent)

- (hyphen)

Activate the next open window in the frontmost app. See
“Layering.”

`

`

Activate the previous open window in the frontmost app.
See “Layering.”

`

Move focus to the window drawer.
Decrease the size of the selected item (equivalent to the
Smaller command). See “The Format Menu.”

-

-

Zoom out when screen zooming is on. See Accessibility
Overview for OS X.

{ (left
bracket)

{

Left-align a selection (equivalent to the Align Left
command). See “The Format Menu.”

} (right
bracket)

}

Right-align a selection (equivalent to the Align Right
command). See “The Format Menu.”

| (pipe)

|

Center-align a selection (equivalent to the Align Center
command). See “The Format Menu.”
Display the Spelling window (equivalent to the Spelling

https://developer.apple.com/library/mac/documentation/userexperience/conceptual/applehiguidelines/KeyboardShortcuts/KeyboardShortcuts.html
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: (colon)

:

command). See “The Edit Menu.”

;
(semicolon)

;

Find misspelled words in the document (equivalent to the
Check Spelling command). See “The Edit Menu.”

, (comma)

,

Open the app's preferences window (equivalent to the
Preferences command). See “The App Menu.”

. (period)
? (question
mark)

,

Decrease screen contrast. See Accessibility Overview for OS
X.

.

Increase screen contrast. See Accessibility Overview for OS
X.

?

Open the app's Help menu. See “The Help Menu.”

/ (forward
slash)

/

Turn font smoothing on or off.

= (equal
sign)

=

Increase the size of the selected item (equivalent to the
Bigger command). See “The Format Menu.”

=

Zoom in when screen zooming is on. See Accessibility
Overview for OS X.

3

Capture the screen to a file.

3

3
4

4

Capture a selection to a file.
4

8

Capture the screen to the Clipboard.

Capture a selection to the Clipboard.
Turn screen zooming on or off. See Accessibility Overview
for OS X.

8

8

Invert the screen colors. See Accessibility Overview for OS X.

A

A

Highlight every item in a document or window, or all
characters in a text field (equivalent to the Select All
command). See “The Edit Menu.”

B

B

Boldface the selected text or toggle boldfaced text on and
off (equivalent to the Bold command). See “The Edit Menu.”

https://developer.apple.com/library/mac/documentation/userexperience/conceptual/applehiguidelines/KeyboardShortcuts/KeyboardShortcuts.html
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Duplicate the selected data and store on the Clipboard
(equivalent to the Copy command). See “The Edit Menu.”
C

Display the Colors window (equivalent to the Show Colors
command). See “The Format Menu.”

C

Copy the style of the selected text (equivalent to the Copy
Style command). See “The Format Menu.”

C

Copy the formatting settings of the selected item and store
on the Clipboard (equivalent to the Copy Ruler command).
See “The Format Menu.”

D

Show or hide the Dock. See “The Dock.”

D

Display the definition of the selected word in the Dictionary
app.

E

E

Use the selection for a find operation. See “Find Windows.”

F

F

Open a Find window (equivalent to the Find command). See
“The Edit Menu.”

G

F

Jump to the search field control. See “Search Field.”

F

Enter full screen.
Find the next occurrence of the selection (equivalent to the
Find Next command). See “The Edit Menu.”

G

G

H

Hide the windows of the currently running app (equivalent
to the Hide AppName command). See “The App Menu.”

H

H

I

Find the previous occurrence of the selection (equivalent to
the Find Previous command). See “The Edit Menu.”

Hide the windows of all other running apps (equivalent to
the Hide Others command). See “The App Menu.”

I

Italicize the selected text or toggle italic text on or off
(equivalent to the Italic command). See “The Format Menu.”

I

Display an Info window. See “Inspectors.”
I

Display an inspector window. See “Inspectors.”

https://developer.apple.com/library/mac/documentation/userexperience/conceptual/applehiguidelines/KeyboardShortcuts/KeyboardShortcuts.html
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J

J

Scroll to a selection.

M

M

Minimize the active window to the Dock (equivalent to the
Minimize command). See “The Window Menu.”
Minimize all windows of the active app to the Dock
(equivalent to the Minimize All command). See “The Window
Menu.”

M

N

N

Open a new document (equivalent to the New command).
See “The File Menu.”

O

O

Display a dialog for choosing a document to open
(equivalent to the Open command). See “The File Menu.”

P

P

Display the Print dialog (equivalent to the Print command).
See “The File Menu.”
Display a dialog for specifying printing parameters
(equivalent to the Page Setup command). See “The File
Menu.”

P

Q

Quit the app (equivalent to the Quit command). See “The
App Menu.”

Q

Log out the current user (equivalent to the Log Out
command).

Q
Q
S

Save a new document or save a version of a document. See
“The File Menu.”

S

S

T

U

Not used (legacy equivalent to the Save As command). See
“The File Menu.”
Display the Fonts window (equivalent to the Show Fonts
command). See “The Format Menu.”

T

T

U

Log out the current user without confirmation.

Show or hide a toolbar (equivalent to the Show/Hide Toolbar
command). See “The View Menu” and “Designing a Toolbar.”
Underline the selected text or turn underlining on or off
(equivalent to the Underline command). See “The Format
Menu.”

Insert the Clipboard contents at the insertion point
https://developer.apple.com/library/mac/documentation/userexperience/conceptual/applehiguidelines/KeyboardShortcuts/KeyboardShortcuts.html
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V

V

(equivalent to the Paste command). See “The File Menu.”
Apply the style of one object to the selected object
(equivalent to the Paste Style command). See “The Format
Menu.”

V

V

V

W
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Apply the style of the surrounding text to the inserted
object (equivalent to the Paste and Match Style command).
See “The Edit Menu.”
Apply formatting settings to the selected object (equivalent
to the Paste Ruler command). See “The Format Menu.”
Close the active window (equivalent to the Close command).
See “The File Menu.”

W

W

Close a file and its associated windows (equivalent to the
Close File command). See “The File Menu.”

W

Close all windows in the app (equivalent to the Close All
command). See “The File Menu.”

X

X

Remove the selection and store on the Clipboard (equivalent
to the Cut command). See “The Edit Menu.”

Z

Z

Reverse the effect of the user's previous operation
(equivalent to the Undo command). See “The Edit Menu.”
Z

(right
arrow)

Reverse the effect of the last Undo command (equivalent to
the Redo command). See “The Edit Menu.”
Change the keyboard layout to current layout of Roman
script.
Extend selection to the next semantic unit, typically the end
of the current line.
Extend selection one character to the right.
Extend selection to the end of the current word, then to the
end of the next word.
Move focus to another value or cell within a view, such as a
table. See Accessibility Overview for OS X.

(left

Change the keyboard layout to current layout of system

https://developer.apple.com/library/mac/documentation/userexperience/conceptual/applehiguidelines/KeyboardShortcuts/KeyboardShortcuts.html
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script.
Extend selection to the previous semantic unit, typically the
beginning of the current line.
Extend selection one character to the left.
Extend selection to the beginning of the current word, then
to the beginning of the previous word.
Move focus to another value or cell within a view, such as a
table. See Accessibility Overview for OS X.

(up
arrow)

Extend selection upward in the next semantic unit, typically
the beginning of the document.
Extend selection to the line above, to the nearest character
boundary at the same horizontal location.
Extend selection to the beginning of the current paragraph,
then to the beginning of the next paragraph.
Move focus to another value or cell within a view, such as a
table. See Accessibility Overview for OS X.

(down
arrow)

Extend selection downward in the next semantic unit,
typically the end of the document.
Extend selection to the line below, to the nearest character
boundary at the same horizontal location.
Extend selection to the end of the current paragraph, then
to the end of the next paragraph (include the paragraph
terminator, such as Return, in cut, copy, and paste
operations).
Move focus to another value or cell within a view, such as a
table. See Accessibility Overview for OS X.
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